Home > Cannot Load > Cannot Load Module Libclntsh A Shr O

Cannot Load Module Libclntsh A Shr O

This seems kind of silly to me. Ivan Tuda replied Nov 5, 2007 I am familiar with this note, and tried your solution but it still doesn't work... Note 593582 addresses this issue. Join Us! *Tek-Tips's functionality depends on members receiving e-mail. have a peek at this web-site

Top White Papers and Webcasts Popular Business Intelligence with SharePoint 2010 Related Return Path Email Intelligence Report Return Path Email Metrics Troubleshooter MoreWhitePapers Best Answer 0 Mark this reply as the Read Alert log file in 11G RMAN Delete old archivelogs lib/libclntsh.a(shr.o) could not be loaded ► August (3) ► July (9) ► June (5) ► May (1) ► April (20) ► Make sure that the same version of Oracle client library is installed on all machines listed in APT configuration file. The environment variable that was set to the system is: LIBPATH=/usr/lib:/lib:/usr/sap/Q11/SYS/exe/run :/oracle/P11/920_64/lib:/oracle/P11/920_64/lib32 Top Best Answer 0 Mark this reply as the best answer?(Choose carefully, this can't be changed) Yes | No http://scn.sap.com/thread/1064169

Regards Top Best Answer 0 Mark this reply as the best answer?(Choose carefully, this can't be changed) Yes | No Saving... In case of aix, .a and .so are not same as on other unix systems. For instance: Summary Symptom When you start a tool, the system issues errors of the following kind: /usr/lib/dld.sl: Bad magic number for shared library: /usr/lib/dld.sl: Exec format error exec(): 0509-036 Skip to Content Open navigation Account Settings Notifications Followed Activities Logout Search Your browser does not support JavaScript.

Any help would be appreciated. CheckDB is able to finish with ora user, but not with adm user. The two are different: ========== root@lipossrp01ga: # ls -l libgpgme.* -rwxr-xr-x 1 root system 922675 Jan 04 09:13 libgpgme.a -rwxr-xr-x 1 root system 865 Dec 19 09:40 libgpgme.la -rwxr-xr-x 1 root Is someone having same problems?

But it seems silly. Remove advertisements Sponsored Links Clovis_Sangrail View Public Profile Find all posts by Clovis_Sangrail

#6 01-09-2012 shriashishpatil Registered User Join Date: My listener is at 10.2.0.2.0 version, should I downgrade it? Already a member? http://www.tek-tips.com/viewthread.cfm?qid=1198751 Thanks, Raj Top Best Answer 0 Mark this reply as the best answer?(Choose carefully, this can't be changed) Yes | No Saving...

And often in conjuction with a faling "magic number". Rasul Allah (sal Allahu alaihi wa sallam) said: "Restore the trusts of those who trust you, and deal not falsely with him who deals falsely with you." [Abu Dawud, Tirmidhi] Search Could that be the issue? If the note doesn't help then you just need to find libclntsh.a(as root run "find / |grep libclntsh.a" and make sure the path to that library is in your library path.

Janz has Oracle 9 and not Oracle 10g. For example, you will find like below for DataStage 7.5x on HP-UX(Itanium): /opt/DS753/Ascential/DataStage/PXEngine/lib$ ls -l *oracle* -rwxr-xr-x 1 dsadm dstage 6542352 Nov 6 2007 liborchoracle10ghpia64.so -rwxr-xr-x 1 dsadm dstage 6542320 Nov Ivan Tuda replied Oct 31, 2007 We're using unix, ofcourse, IBM AIX. Thank you very much for all your support.

number of processes per user.Stefan RE: Cannot load module libclntsh.a(shr.o) khalidaaa (TechnicalUser) (OP) 7 Mar 06 07:55 Thanks guysi've managed to solve the problem!!!the service that i was trying to start Check This Out Clovis_Sangrail View Public Profile Find all posts by Clovis_Sangrail #4 12-27-2011 zaxxon code tag tagger Join Date: Sep 2007 Last Activity: 7 November 2016, 8:19 AM EST B.E,M.S,M.B.A,P.M.P,C.S.M Experience: is what you get soon after you need it. I have not yet tried rebooting this system.

Maybe we can solve this by > patching brtools with new patch? > > > > > ------------------- Marcelo Bitencourt AdministraĆ§Ć£o SAP R/3 BASIS Database & SAP Management Top Best Answer Also, checkdb through brtools is successful with ora user, but fails with adm user. All rights reserved. Source Join UsClose Real Life Sysadmin Wednesday, November 7, 2012 Dependent module libclntsh.a(shr.o) could not be loaded I've found this error "Dependent module libclntsh.a(shr.o) could not be loaded" on many occasions, but

Note: LIBPATH in above example is shared library path variable for AIX, please use LD_LIBRARY_PATH for Linux, Solaris, and HP-UX(Itanium), SHLIB_PATH for HP-UX(PA-RISC) instead. Did you change any library meantime? I'm guessing that libclntsh is also in there somewhere...

CheckDB output error Ivan Tuda asked Oct 31, 2007 | Replies (24) Hi2all!

Spencer Matthews replied Oct 31, 2007 This is a problem with your library path in the environment of sidadm. External program terminated with exit code 255 BRCONNECT returned error status E Job finished We checked environment variables and links that are connected with that module, and nothing helps. cheers Posted by sameer at 11:48 AM Reactions: No comments: Post a Comment Newer Post Older Post Home Subscribe to: Post Comments (Atom) Backup & Recovery Docs Blog Archive ► 2016 It turned out the only module inside the libgpgme.a archive was --- libgpgme.so.11 !

RE: Cannot load module libclntsh.a(shr.o) stefanhei (TechnicalUser) 2 Mar 06 08:54 Did you try a relink all as oracle8i?I've always done it this way: install oracle choosing software only then copy All rights reserved.Unauthorized reproduction or linking forbidden without expressed written permission. It spat errors like: ========== 0509-150 Dependent module /usr/local/lib/libgpgme.a(libgpgme.so.11) could not be loaded. 0509-153 File /usr/local/lib/libgpgme.a is not an archive or the file could not be read properly. 0509-026 System error: http://dekovsoft.com/cannot-load/cannot-load-module-libclntsh-so.html But for some reason a few (but not all) of the systems would throw the error "Dependent module libclntsh.a(shr.o) could not be loaded" when I tried running brconnect, brspace or other

Oh well, at least it works. Is it possible that the library you changed is built using higher/lower version of compiler than the other libraries? -Ashish The Following User Says Thank You to shriashishpatil For This Useful Many times restart of the system solves our problem. cd `cat /.dshome` . ./dsenv # dot space dot slash dsenv - Make sure the Oracle library path is in shared library path using echo $LIBPATH # on AIX echo $LD_LIBRARY_PATH

The people who supplied the software are due back from the holidays tomorrow, I hope to hear from then soon. ---------- Post updated at 12:54 PM ---------- Previous update was at I quickly created a new softlink, and lo and behold. CheckDB is able to finish > with ora user, but not with adm user. As a solution, I have just copied the /sapmnt//exe to /sapmnt/QAS/exe and it works." The wrong version of BRTools was being used.

I've found sources that say LIBPATH is the shared library variable , and others that say LIB_PATH, so I set both: Code: ========================= root@lipossrp01ga: # echo $gtm_dist /SCA/gtm_dist-V5.4-002A/ root@lipossrp01ga: # echo Now, after we execute checkdb in db13, following > message occurs: > > Job started > > Step 001 started (program RSDBAJOB, variant &0000000000903, user > ID ITUDJA) > Execute logical Magic being somewhat non-descriptive, when they only mean 32 or 64 bit.... David Caddick replied Mar 16, 2009 Hi Janz, Thank you for letting us know your problem is solved and also for giving the solution to your problem.

Paul McCrimmon | A c x i o m / S A P B A S I S 630.944.3689 office | 630.564.2758 wireless 3333 Finley Road | Downers Grove, IL 60515 Any more ideas maybe? External program terminated with exit code 255 BRCONNECT returned error status E Job finished Value of LIBPATH environment: /usr/lib:/lib:/usr/sap/Q11/SYS/exe/run:/oracle /P11/920_64/lib:/oracle/P11/920_64/lib32 Thank you very much... But I followed the traces around, and finally I found the culprit.

Start a new thread here 1678646 Related Discussions CheckDB syntax error tablespace datafile is full Deleting buffers from front end abap/buffersize for bi Release scheduled jobs Statistics are not upto date And it took me a while to find the cause of the problem. We have upgraded Oracle from version 9.2.0.7 to 10.2.0.2 with br*tools from 640 to 700, patch 28, and kernel is 640, patch level 155. Some components may not be visible.

I do need to try that, though. Has anybody ever encountered something like this?