Home > Cannot Read > Cannot Read Termcap Database Using Dumb Terminal Settings Python

Cannot Read Termcap Database Using Dumb Terminal Settings Python

We have tested it at our end. If you have received this e-mail in error, please notifythe sender immediately by reply e-mail and delete this message. For example, if placed as the first line within the test() function code block: import pdb def test(what): pdb.set_trace() # <-- new location if what == 0: return 0 print('dream lvl: reply | permalink Gabe Nell Thanks Dharmendra, however in Ubuntu there is no package called libtermcap, though it has been suggested that the libncurses5-dev package provides this [1]. this contact form

Did you mean to say: recur = test(what-1) Also, you might want to move the call to the pdb.set_trace() to precisely where it should begin. Discussion Navigation viewthread | post Discussion Overview grouppgsql-bugs @ categoriespostgresql postedDec 29, '10 at 7:09p activeJul 22, '11 at 11:31a posts13 users8 websitepostgresql.org irc#postgresql Preferences responses expanded Hotkey:s font variable Hotkey:f We recommend upgrading to the latest Safari, Google Chrome, or Firefox. Do you know the exact Ubuntu package that I need toinstall?Apparently my colleague downloaded and installed a tarball of GNUtermcap 1.3.1.I'm still not clear how this passed our internal testing though;

o Is asr33 in your termcap database? Those settings are usually done in the various profiles when a user logs in from a terminal but apparently there's a problem for user norman.[EDIT]Python 2.7 was first shipped with Lion Let me ask my colleague and get back to you.--Dave PageBlog: http://pgsnake.blogspot.comTwitter: @pgsnakeEnterpriseDB UK: http://www.enterprisedb.comThe Enterprise PostgreSQL Company reply | permalink Dharmendra Goyal If you install libtermcap then it will start reply | permalink Gabe Nell Just checking back to see if there have been any updates on this.

I don't see any global "disable readline" flag, but you may be able to get that effect by deleting all the key mappings, or some such silliness. No TERMINFO customization there. Here's mine from 10.9.5, where user-defined terminfo entries are working okay. $ brew config HOMEBREW_VERSION: 0.9.5 ORIGIN: https://github.com/Homebrew/homebrew.git HEAD: 33bae41f9befda0d8c06ede428bcb69b31dfa21c Last commit: 4 days ago HOMEBREW_PREFIX: /usr/local HOMEBREW_REPOSITORY: /usr/local HOMEBREW_CELLAR: /usr/local/Cellar xcambar commented Jan 30, 2016 It does not. $ /usr/bin/tput cols 158 $ echo $? 0 apjanke commented Jan 30, 2016 I wonder if there is some terminfo customization that is

All rights reserved. I notice when I connect to the Python interpreter on the machine running Indigo Server (it's local name is "homemaker") I get this:Code: Select allLela-Laptop:~ norman$ ssh [email protected] -t "/Library/Application\ Support/Perceptive\ Traceback (most recent call last): File "/Applications/Wing101.app/Contents/Resources/src/debug/tserver/sandbox.py", line 2, in if __name_ == 'main': File "/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/pdb.py", line 1579, in set_trace Pdb().set_trace(sys.getframe().f_back) File "/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/bdb.py", line 251, in set_trace sys.settrace(self.trace_dispatch) File "/Applications/Wing101.app/Contents/Resources/bin/3.4/src/debug/tserver/dbgserver.py", https://mail.python.org/pipermail/python-list/2011-December/615760.html One of my colleagues has testedthe issue reported and confirmed that installing the OS's termcappackage should solve the problem.Ubuntu doesn't seem to use termcap, an apt-cache search for termcapturns up nothing

One of my colleagues has testedthe issue reported and confirmed that installing the OS's termcappackage should solve the problem.Ubuntu doesn't seem to use termcap, an apt-cache search for termcapturns up nothing Regards, Martin Martin Muenstermann at Feb 11, 2011 at 2:07 pm ⇧ Hi,the problem still exists in the 9.0.3 package provided by EnterpriseDB:psql (9.0.3)Type "help" for help.Cannot read termcap database;using dumb However I tried this and I still get thesame error. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 1,053 Star 29,484 Fork 14,002 Homebrew/legacy-homebrew Code Issues 1 Pull requests 0 Projects

The idea that somebody would> > want to turn it off (even for testing) disturbs me deeply.> > I know! https://forum.fortinet.com/tm.aspx?m=119746 Terms Privacy Security Status Help You can't perform that action at this time. [email protected]:~ $ tic xterm-256color-italic.terminfo [email protected]:~ $ export TERM=xterm-256color-italic [email protected]:~ $ brew install jasper ==> Downloading https://homebrew.bintray.com/bottles/jasper-1.900.1.mavericks.bo Already downloaded: /Library/Caches/Homebrew/jasper-1.900.1.mavericks.bottle.1.tar.gz ==> Pouring jasper-1.900.1.mavericks.bottle.1.tar.gz 🍺 /usr/local/Cellar/jasper/1.900.1: 35 files, 898.0K [email protected]:~ $ In my reply | permalink Javiero09 Hi, try with this: as superuser type: #infocmp -C > /etc/termcap it worked for my -- View this message in context: http://postgresql.1045698.n5.nabble.com/BUG-5807-psql-fails-to-launch-with-Cannot-read-termcap-database-using-dumb-terminal-settings-Aborted-tp3321689p4622693.html Sent from the PostgreSQL -

I think I may need to resortto compiling from source otherwise?? weblink However I tried this and I still get thesame error. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. I solved itby using this command: LD_PRELOAD = /lib/libreadline.so.5 ./psql reply | permalink Moa I am still getting this problem.

post edited by jknap - 2015/02/03 01:38:51 #1 0 Replies Related Threads Jump to: Jump to - - - - - - - - - - [FortiGate / FortiOS UTM features] Do you know the exact Ubuntu package that I need to install? Can you suggest that the appropriate package to install on Ubuntu? navigate here If that's correct, then you can configure its behavior by editing your ~/.inputrc file.

apjanke commented Jul 14, 2016 @jwhitley I tried running a few brew installs under tmux using your updated terminfo entry, and wasn't able to reproduce those error messages. So it's possible that whatever was triggering this was (inadvertently?) fixed on some code paths, but not others. >> brew reinstall neovim ==> Reinstalling neovim/neovim/neovim ==> Cloning https://github.com/neovim/neovim.git Updating /Users/whitley/Library/Caches/Homebrew/neovim--git ==> The easiest method is probably to use virtualenv.

I'm assuming Python uses the standard GNU readline().

Reload to refresh your session. Reload to refresh your session. [lldb-dev] lldb exits automatically on launch Filipe Cabecinhas filcab at gmail.com Wed Apr 18 05:46:08 PDT 2012 Previous message: [lldb-dev] lldb exits automatically on launch Next If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message. At least as of Homebrew/[email protected], I'm not seeing the tput: problem with a typical "bottle-fed" brew update && brew upgrade run.

xcambar commented Feb 2, 2016 The fact you have no problem is already enlightening. You signed in with another tab or window. reply | permalink Related Discussions -ltermcap needed for psql client build on OpenBSD 2.9 getBigDecimal problem Postmaster crash problems with OS X and beta 2 postgresql 7.1 driver Bug #923: psql his comment is here This is on OS X 10.9.5.

policy Source Address question? 3rd party DNS errors Forticlient in Windows 10 Wan2 automatically failover to IPSEC VPN on wan1 Web Rating Overrides not working properly after FortiOs Upgrade All FAQs